FAQ

BA Web and Mobile Apps に関する FAQ です。

ライセンス

解析

カスタム データを使用した解析ができないのはなぜですか?

概要

BA Web App では、カスタム データを用いた解析が可能です。 しかし、カスタム データの座標系の設定によっては、解析実行後に画面が読み込み中のまま遷移しなかったり、インフォグラフィックスやレポートの集計結果が N/A となったりする現象が発生します。

カスタム データは、[カスタム データの設定] ツールから設定できます。

原因

BA Web App に追加したデータの空間参照 (座標系) が以下のもの以外に設定されているため。

  • Web メルカトル図法 (球体補正) (Web Mercator (auxiliary sphere)) (WGS 1984) WKID(EPSG コード): 102100 (3857)

対象のデータの空間参照を ArcGIS Online で確認する方法は以下の通りです。

  • BA Web App の [ファイルのインポート] からインポートしたデータの場合

    1. ArcGIS Online にサイン インし、[コンテンツ] タブ → [マイ コンテンツ] をクリックします。
    2. [フォルダー] の中の「BA-Project Data」をクリックします。
    3. カスタム データをインポートしたプロジェクト名のレイヤーの名前部分をクリックし、アイテム詳細ページを開きます。
    4. [レイヤー] のうち、インポートしたレイヤーをクリックします。
    5. [URL] 右上の [表示] をクリックします。
    6. [Extent] 内の [Spatial Reference] が「102100 (3857) 」であることを確認します。
  • 自分が所有、もしくは組織内共有された Web レイヤーを BA Web App の [Web マップおよびレイヤー] で参照した場合

    1. ArcGIS Online にて、追加したデータのアイテム詳細ページにアクセスします。
    2. [URL] 右上の [表示] をクリックします。
    3. [Extent] 内の [Spatial Reference] が「102100 (3857) 」であることを確認します。

回避方法

エラーが発生しているデータの座標系を、ArcGIS Pro の [投影変換] ツールで変換し、再度 BA Web App でカスタム データとして設定します。

【ArcGIS Pro での作業】

  1. ArcGIS Pro を起動します。
  2. [ジオプロセシング] ウィンドウを表示し、[データ管理ツール] → [投影変換と座標変換] → [投影変換] をクリックして、ツールを起動します。
  3. [入力データセット、またはフィーチャクラス] で、処理対象のデータを設定します。
  4. [出力データセット、またはフィーチャクラス] で、データの出力先と名称を設定します。
  5. [出力座標系] で、以下の座標系を設定します。

    Web メルカトル図法 (球体補正) (Web Mercator (auxiliary sphere)) (WGS 1984)

  6. [実行] ボタンをクリックして、変換処理を行います。
  7. 出力されたフィーチャクラスを、ArcGIS Online に公開します。

【BA Web App での作業】

  1. BA Web App を起動します。
  2. ヘルプを参考に、公開したフィーチャクラスをカスタム データとして設定します。